MPLS – Primeros pasos

mpls_gns31
Nunca me he llevado bien con GNS3.
Todos los ordenadores que he tenido no han sido especialmente potentes y siempre se ha acabado colgando el GNS3.

Toquemos madera.

Lo primero: Imprescindibles para el estudio de MPLS:

Darrens Blog : Muy claro y muy conciso. Genial.

MPLS VPN Configuration Example.

PacketLife.net.

R1

R1#configure terminal
R1(config)#ip cef
R1(config)#mpls ip
R1(config)#interface gi1/0
R1(config-if)#mpls ip
R1(config-if)#end
*May 3 19:37:58.011: %LDP-5-NBRCHG: LDP Neighbor 192.168.1.2:0 (1) is UP

R1#show ip interface brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 unassigned YES unset administratively down down
GigabitEthernet1/0 192.168.1.1 YES manual up up
GigabitEthernet2/0 unassigned YES unset administratively down down
R1#configure terminal
R1(config)#router ospf 100
R1(config-router)#network 192.168.1.0 0.0.0.255 area 0
R1(config-router)#end

r1mpls1

R2
R2#configure terminal
R2(config)#ip cef
R2(config)#mpls ip
R2(config)#interface gi1/0
R2(config-if)#ip address 192.168.1.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#end

R2(config)#interface gi2/0
R2(config-if)#ip address 172.16.0.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#end

R2(config)#interface gi2/0
R2(config-if)#mpls ip
R2(config-if)#exit
R2(config)#ip cef
R2(config)#mpls ip
R2(config)#end

R2(config)#router ospf 100
R2(config-router)#network 192.168.1.0 0.0.0.255 area 0
R2(config-router)#network 172.16.0.0 0.0.0.255 area 0
R2(config-router)#end
R2#

r2mpls1

 

R3

R3#configure terminal
R3(config)#interface gi1/0
R3(config-if)#ip address 172.16.0.2 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#end

R3#configure terminal
R3(config)#interface gi2/0
R3(config-if)#ip address 10.20.20.1 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#end

R3(config)#interface gi1/0
R3(config-if)#mpls ip
R3(config-if)#end

R3(config)#interface gi2/0
R3(config-if)#mpls ip
R3(config-if)#end

R3#configure terminal
R3(config)#ip cef
R3(config)#mpls ip
R3(config)#end

R3(config)#router ospf 100
R3(config-router)#network 172.16.0.0 0.0.0.255 area 0
R3(config-router)#network 10.20.20.0 0.0.0.255 area 0
R3(config-router)#end
R3#

r3mpls1

r3mpls2

 

R4

R4#configure terminal
R4(config)#ip cef
R4(config)#mpls ip
R4(config)#end

R4#configure terminal
R4(config)#interface gi1/0
R4(config-if)#ip address 10.20.20.2 255.255.255.0
R4(config-if)#no shutdown
R4(config-if)#
R4(config-if)#mpls ip
R4(config-if)#end

R4#configure terminal
R4(config)#router ospf 100
R4(config-router)#network 10.20.20.0 0.0.0.255 area 0
R4(config-router)#end
R4#

r4mpls1

 

 

Comments are closed.