Seguimos con MPLS

mplsbackbone1
Vamos a seguir practicando configurando MPLS en GNS3. Esta no es la topología habitual en una configuración MPLS.

Cuando estudies MPLS, la configuración habitual será la siguiente:

mpls_topologia_tipica1

Donde CE son los routers que pertenecen a la red de los clientes.

PE  son los routers del proveedor que conectan con los de los clientes.

P routers que pertenecen a la red del proveedor.

Pero vamos a practicar con MPLS sin meter todavía VRF ni configurar el protocolor de enrutamiento MP-BGP entre los routers PE del proveedor.

Para ese laboratorio, me he apoyado en esta web:
GNS3 Lab: Introduction to MPLS Layer 3 VPN Part 1
Y muy recomendable esta otra:
MPLS VPN

IMPRESCINDIBLE. Bájate este PDF:
Apricot 2015

 

 

R1

R1#configure terminal
R1(config)#ip cef
R1(config)#mpls ip
R1(config)#end

R1#show ip interface brief
Interface IP-Address OK? Method Status Protocol

GigabitEthernet1/0 192.168.10.1 YES manual up up
GigabitEthernet2/0 192.168.30.1 YES manual up up

R1#configure terminal
R1(config)#mpls label range 1000 1999

R1(config)#interface loopback0
R1(config-if)#ip address 1.1.1.1 255.255.255.255
R1(config-if)#end
R1#

R1#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#interface gi1/0
R1(config-if)#mpls ip
R1(config-if)#exit
R1(config)#interface gi2/0
R1(config-if)#mpls ip
R1(config-if)#exit
R1(config)#end

R1#show ip interface brief

GigabitEthernet1/0 192.168.10.1 YES manual up up
GigabitEthernet2/0 192.168.30.1 YES manual up up
Loopback0 1.1.1.1 YES manual up up
R1#configure terminal
R1(config)#router ospf 100
R1(config-router)#network 192.168.10.0 0.0.0.255 area 0
R1(config-router)#network 192.168.30.0 0.0.0.255 area 0
R1(config-router)#network 1.1.1.1 0.0.0.0 area 0
R1(config-router)#end
R1#

 

 

mplsr1101

mplsr1102

mplsr1103

 

mplsr11104

 

R4

R4#configure terminal
R4(config)#interface gi1/0
R4(config-if)#ip address 192.168.20.2 255.255.255.0
R4(config-if)#no shutdown
R4(config-if)#end
R4#configure terminal
R4(config)#interface gi2/0
R4(config-if)#ip address 192.168.40.2 255.255.255.0
R4(config-if)#no shutdown
R4(config-if)#end

R4#configure terminal
R4(config)#ip cef
R4(config)#mpls ip
R4(config)#interface gi1/0
R4(config-if)#mpls ip
R4(config-if)#exit
R4(config)#interface gi2/0
R4(config-if)#mpls ip
R4(config-if)#exit
R4(config)#

R4#show ip interface brief
GigabitEthernet1/0 192.168.20.2 YES manual up up
GigabitEthernet2/0 192.168.40.2 YES manual up up
Loopback0 4.4.4.4 YES manual up up

R4#configure terminal
R4(config)#router ospf 100
R4(config-router)#network 192.168.20.0 0.0.0.255 area 0
R4(config-router)#network 192.168.40.0 0.0.0.255 area 0
R4(config-router)#network 4.4.4.4 0.0.0.0 area 0
R4(config-router)#end

mplsr21101

mplsr41102

 

R2

mplsr22001

mplsr22204

R3

mplsr31101

mplsr32202

 

tracerouter31

 

 

Comments are closed.