Y acabamos con MPLS

topologia_mpls_5mayo1
Lo siento, va a reventar el GNS3.
No tengo suficiente ordenador para probar como a mi me gustaría el protocolo MPLS en GNS3.
Creo que como mínimo necesitaríamos poder configurar 7 routers en el GNS3.
En mi caso, trabajando con 4 routers mi ordenador empieza que me muero, que me muero …
Vamos a ver hasta dónde he llegado.
Me he basado por completo en:
PacketLife.net
El pdf de Apricot

Vamos con las configuraciones:

R1

R1#show ip interface brief
GigabitEthernet1/0 192.168.10.2 YES manual up up
GigabitEthernet2/0 unassigned YES unset administratively down down

R1(config)#router ospf 1
R1(config-router)#network 192.168.10.0 0.0.0.255 area 0
R1(config-router)#end

R1mpls5mayo1

 R2

Se supone que era el router del Cliente 2. Se queda fuera. Bye.

R3

Este sería el router PE1.

R3#configure terminal
R3(config)#interface gi1/0
R3(config-if)#ip address 192.168.10.1 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#end

R3#configure terminal
R3(config)#ip vrf VPN-A
R3(config-vrf)#rd 1:1
R3(config-vrf)#route-target export 100:1
R3(config-vrf)#route-target import 100:1
R3(config-vrf)#exit
R3(config)#interface gi1/0
R3(config-if)#ip vrf forwarding VPN-A
% Interface GigabitEthernet1/0 IP address 192.168.10.1 removed due to enabling VRF VPN-A
R3(config-if)#ip address 192.168.10.1 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#end

R3#configure terminal
R3(config)#interface gi2/0
R3(config-if)#ip address 130.130.1.1 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#mpls ip
R3(config-if)#exit
R3(config)#router ospf 1
R3(config-router)#network 130.130.1.0 0.0.0.255 area 0
R3(config-router)#end
R3#

R3(config)#interface loopback0
R3(config-if)#ip address 1.1.1.1 255.255.255.255
R3(config-if)#end

R3(config)#router bgp 1
R3(config-router)#neighbor 2.2.2.2 remote-as 1
R3(config-router)#neighbor 2.2.2.2 update-source loopback0
R3(config-router)#address-family vpnv4
R3(config-router-af)#neighbor 2.2.2.2 activate
R3(config-router-af)#end

R3#configure terminal
R3(config)#router ospf 1
R3(config-router)#network 1.1.1.1 0.0.0.0 area 0
R3(config-router)#end

R3#configure terminal
R3(config)#router ospf 2 vrf VPN-A
R3(config-router)#network 192.168.10.0 0.0.0.255 area 0
R3(config-router)#redistribute bgp 1 subnets
R3(config-router)#end
R3#

R3#configure terminal
R3(config)#router bgp 1
R3(config-router)#address-family ipv4 vrf VPN-A
R3(config-router-af)#redistribute ospf 2
R3(config-router-af)#end
R3#

R3#configure terminal
R3(config)#router ospf 2
R3(config-router)#redistribute bgp 1 subnets
R3(config-router)#end
R3#

R3mpls5mayo214

R3mpls5mayo3

R3mpls5mayo4

R4

Este route sería PE2 del proveedor.

R4#configure terminal
R4(config)#interface gi1/0
R4(config-if)#ip address 130.130.1.2 255.255.255.0
R4(config-if)#no shutdown
R4(config-if)#end

R4#configure terminal
R4(config)#interface loopback0
R4(config-if)#ip address 2.2.2.2 255.255.255.255
R4(config-if)#end

R4#configure terminal
R4(config)#router bgp 1
R4(config-router)#neighbor 1.1.1.1 remote-as 1
R4(config-router)#neighbor 1.1.1.1 update-source loopback0
R4(config-router)#address-family vpnv4
R4(config-router-af)#neighbor 1.1.1.1 activate
R4(config-router-af)#end

R4#configure terminal
R4(config)#interface gi1/0
R4(config-if)#mpls ip
R4(config-if)#exit
R4(config)#router ospf 1
R4(config-router)#network 130.130.1.0 0.0.0.255 area 0
R4(config-router)#end
R4#

R4#configure terminal
R4(config)#router ospf 1
R4(config-router)#network 2.2.2.2 0.0.0.0 area 0
R4(config-router)#end

R4#show ip interface brief
GigabitEthernet1/0 130.130.1.2 YES manual up up
GigabitEthernet2/0 unassigned YES unset administratively down down
Loopback0 2.2.2.2 YES manual up up
R4#configure terminal
R4(config)#ip vrf VPN-A
R4(config-vrf)#rd 1:1
R4(config-vrf)#route-target export 100:1
R4(config-vrf)#route-target import 100:1
R4(config-vrf)#exit
R4(config)#interface gi2/0
R4(config-if)#ip vrf forwarding VPN-A
R4(config-if)#ip address 192.168.20.1 255.255.255.0
R4(config-if)#no shutdown
R4(config-if)#end
R4#

R4#configure terminal
R4(config)#router ospf 2 vrf VPN-A
R4(config-router)#network 192.168.20.0 0.0.0.255 area 0
R4(config-router)#redistribute bgp 1 subnets
R4(config-router)#end
R4#

R4#configure terminal
R4(config)#router bgp 1
R4(config-router)#address-family ipv4 vrf VPN-A
R4(config-router-af)#redistribute ospf 2
R4(config-router-af)#end

R4#configure terminal
R4(config)#router ospf 2
R4(config-router)#redistribute bgp 1 subnets
R4(config-router)#end

R4mpls5mayo1

R4mpls5mayo2

R4mpls5mayo3

R5

R5#configure terminal
R5(config)#router ospf 1
R5(config-router)#network 192.168.20.0 0.0.0.255 area 0
R5(config-router)#end
R5#

R5mpls5mayo1

 R6

Este tampoco juega.

Me voy a la playa.

 

Comments are closed.