Configurando Hookflash en teléfonos analógicos.

hookflash23

Este es un laboratorio muy bonito. La primera vez que lo vi fue en el estupendo blog de Antonio Maciá, en el post UC560: Call transfer from analog phones

Sin embargo, en mi caso, la solución la he encontrado en el foro de Cisco Support Community, en este hilo: Transfer calls from analog phone on FXS port

Para este laboratorio necesitamos:

1 Router 2620XM
1 Módulo NM-2V Cisco
1 Tarjeta VIC 2FXS
1 Switch Cisco Catalyst 2960
2 Teléfonos analógicos
1 Teléfono Cisco IP Phone 7960
1 Ordenador con Cisco Ip Communicator
1 Cisco ATA 186

La configuración del dhcp en el router y del CME no debería ser a estas altura mayor problema. Ya somos todos expertos.

ip dhcp excluded-address 192.168.4.1 192.168.4.10
ip dhcp excluded-address 30.30.0.1 30.30.0.10
!
ip dhcp pool Datos
network 192.168.4.0 255.255.255.0
default-router 192.168.4.1
!
ip dhcp pool Voz
network 30.30.0.0 255.255.255.0
default-router 30.30.0.1
option 150 ip 30.30.0.1

!
interface FastEthernet0/0.5
description VLAN VOZ
encapsulation dot1Q 5
ip address 30.30.0.1 255.255.255.0
!
interface FastEthernet0/0.10
description VLAN DATOS
encapsulation dot1Q 10
ip address 192.168.4.1 255.255.255.0
!

voice-port 1/0/0
!
voice-port 1/0/1

dial-peer voice 2 pots
destination-pattern 9123456789
port 1/0/1
!

telephony-service
max-ephones 4
max-dn 10
ip source-address 30.30.0.1 port 2000
create cnf-files version-stamp Jan 01 2002 00:00:00
max-conferences 4 gain -6
!
!
ephone-dn 1 dual-line
number 5001

ephone-dn 2 dual-line
number 5002
!

ephone-dn 3 dual-line
number 5003
!
ephone 1
mac-address 0030.94C2.906C
button 1:1

ephone 2
mac-address ACA0.166E.32C1
button 1:2

ephone 3

ephone 4
mac-address 00C0.9F70.94D9
button 1:3
!

Router#show voice port summary
IN OUT
PORT CH SIG-TYPE ADMIN OPER STATUS STATUS EC
=============== == ============ ===== ==== ======== ======== ==
1/0/0 — fxs-ls up dorm on-hook idle y
1/0/1 — fxs-ls up dorm on-hook idle y

Router#show voice port 1/0/0 | include flash
Hookflash-in Timing is set to max=1000 ms, min=150 ms
Hookflash-out Timing is set to 400 ms
Router#

Hummm… Como explica muy bien Antonio Maciá en su blog, esos son los valores por defecto de la duración del corte en los puertos FXS.

¿Tendré yo el mismo problema en este laboratorio?

Pos si.

Hago una llamada del 5001 al 9123456789, funciona, quiero pasar la llamada al 5003 y cuando le doy a la teclar “R” ni caso.  Sin embargo cuando cuelgo con el dedo si me da el segundo tono para que pueda marcar el 5003.

El teléfono analógico 9123456789 está en el puerto 1/0/1.

Cambiamos los valores que vienen por defecto.

Router(config)#voice-port 1/0/1
Router(config-voiceport)#timing hookflash-in 120 60
Router(config)#end

120 es el valor máximo – 60 es el valor mínimo.

debug vpm signal
*Mar 1 18:12:28.879: htsp_process_event: [1/0/1, FXSLS_CONNECT, E_DSP_SIG_0100]fxsls_offhook_onhook, HF duration Max=120, HF duration Min=60
*Mar 1 18:12:28.879: htsp_timer - 120 msec
*Mar 1 18:12:28.979: htsp_process_event: [1/0/1, FXSLS_CONNECT, E_DSP_SIG_1100]fxsls_offhook_offhookhtsp_hook_flash_ind
*Mar 1 18:12:28.979: htsp_timer_stop htsp_call_feature:feature 5

Debería haber funcionado. El tiempo del corte son 100ms. Está entre Min=60 y Max=120. Sin embargo no ha funcionado.

Miro en el foro y tal como dice Paolo Bevilacqua, le pongo el valor de 80ms. Y entonces si que funciona.

Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#voice-port 1/0/1
Router(config-voiceport)#timing hookflash 80
Router(config-voiceport)#end

Router#show voice port 1/0/1 | i fla
Hookflash-in Timing is set to max=80 ms, min=0 ms
Hookflash-out Timing is set to 400 ms
Router#

debug vpm signal

*Mar 1 19:05:13.487: htsp_process_event: [1/0/1, FXSLS_CONNECT, E_DSP_SIG_0100]fxsls_offhook_onhook, HF duration Max=80, HF duration Min=0
*Mar 1 19:05:13.487: htsp_timer - 80 msec
*Mar 1 19:05:13.567: htsp_process_event: [1/0/1, FXSLS_CONNECT, E_HTSP_EVENT_TIMER]fxsls_connect_wait_release_req
*Mar 1 19:05:13.567: htsp_timer_stop

 

 

 

 

Comments are closed.