SIP Trunk entre CUCM y CME

siptrunk1
Para esta receta utilizaremos:

1 Router 2801 con IOS c2801-advipservicesk9-mz.151-3.T.bin.
1 CUCM virtualizado en un PC con VMware.
2 Teléfonos ip o softphones.

Necesitarás también Switchs que soporten Vlans. Aunque en mi caso, la configuración es un poco distinta, ya que voy a utilizar el ASA 5505 del post anterior, que me parece comodísimo. Como el ASA es el servidor DHCP, le va a dar una ip al CME del mismo rango que CUCM.
CME y CUCM tienen que poder hacer ping entre ellos.

siptrunk2

Empezamos configurando el CME:

Router#show ip interface brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 unassigned     YES NVRAM up up
FastEthernet0/0.5 20.20.0.1      YES NVRAM up up
FastEthernet0/0.10 192.168.3.1 YES NVRAM up up
FastEthernet0/1 10.10.0.31         YES DHCP    up up

 

El Router es servidor DHCP para voz y datos:

ip dhcp excluded-address 192.168.3.1 192.168.3.10
ip dhcp excluded-address 20.20.0.1 20.20.0.10

ip dhcp pool Datos
network 192.168.3.0 255.255.255.0
default-router 192.168.3.1

ip dhcp pool Voz
network 20.20.0.0 255.255.255.0
default-router 20.20.0.1
option 150 ip 20.20.0.1

interface FastEthernet0/0.5
description VLAN VOZ
encapsulation dot1Q 5
ip address 20.20.0.1 255.255.255.0

interface FastEthernet0/0.10
description VLAN DATOS
encapsulation dot1Q 10
ip address 192.168.3.1 255.255.255.0

interface FastEthernet0/1
ip address dhcp
duplex auto
speed auto

Configuramos dos dial-peers: Llamadas entrantes por el SIP Trunk, y llamadas salientes por el SIP Trunk:

dial-peer voice 1 voip
description **Llamadas entrantes por el SIP TRUNK**
session protocol sipv2
session target ipv4:10.10.0.31
incoming called-number 2…
dtmf-relay h245-alphanumeric
codec g711ulaw

dial-peer voice 2 voip
description **Llamadas salientes por el SIP Trunk**
destination-pattern 1…
session protocol sipv2
session target ipv4:10.10.0.11
dtmf-relay rtp-nte
codec g711ulaw

sip-ua
registrar ipv4:10.10.0.11 expires 3600
sip-server ipv4:10.10.0.11

En voice service voip, autorizamos las conexiones sip to sip

voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip

Yo creo que está todo. Tenemos dos teléfonos ips registrados, el 2001 y el 2002:

telephony-service
no auto-reg-ephone
max-ephones 4
max-dn 10
ip source-address 20.20.0.1 port 2000
cnf-file location flash:
cnf-file perphone
max-conferences 4 gain -6
transfer-system full-consult
create cnf-files version-stamp Jan 01 2002 00:00:00

ephone-dn 1 dual-line
number 2001

ephone-dn 2 dual-line
number 2002

ephone 1
device-security-mode none
mac-address 00A0.D168.2709
button 1:1

ephone 2
device-security-mode none
mac-address 0030.94C2.906C
button 1:2

Por la parte del CME hemos acabado.

Y ahora vamos a la parte del CUCM.

 

sip trunk 2

 

Aquí tenemos un teléfono registrado que es el 1004. Nos vale para el laboratorio.

System > Security > SIP Trunk Security Profile

 

sip trunk 3

 

sip trunk 4

 

Device > Trunk  y creamos uno nuevo:

 

sip trunk 6

 

sip trunk 5

 

Sólo nos falta añadir un Route Pattern

 

Call Routing > Route/Hunt > Route Pattern

 

sip trunk 8

sip trunk 7

 

Y  ya tenemos nuestro flamante SIP Trunk entre CUCM y CME:

siptrunk1

 

¿Esto funciona?

Vamos, a verlo.

Router#debug ccsip message
SIP Call messages tracing is enabled

Y hacemos llamadas del 1004 al 2001 :

INVITE sip:2001@10.10.0.31:5060 SIP/2.0
Via: SIP/2.0/UDP 10.10.0.11:5060;branch=z9hG4bK87620923d
From: <sip:1004@10.10.0.11>;tag=31~e8b7b5a7-1eb5-494d-9850-73b8bd8a98c3-28509490
To: <sip:2001@10.10.0.31>
Date: Tue, 24 Feb 2015 19:10:14 GMT
Call-ID: c19f7480-4ec1cc96-8-b000a0a@10.10.0.11
Supported: timer,resource-priority,replaces
Min-SE: 1800
User-Agent: Cisco-CUCM8.6
Allow: INVITE, OPTIONS, INFO, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY
CSeq: 101 INVITE

….

….

Router#SIP/2.0 200 OK
Via: SIP/2.0/UDP 10.10.0.31:5060;branch=z9hG4bK161301
From: <sip:2001@10.10.0.31>;tag=3F15BC-1EA0
To: <sip:1004@10.10.0.11>;tag=31~e8b7b5a7-1eb5-494d-9850-73b8bd8a98c3-28509490
Date: Tue, 24 Feb 2015 19:10:22 GMT
Call-ID: c19f7480-4ec1cc96-8-b000a0a@10.10.0.11
CSeq: 101 BYE
Content-Length: 0

 

Y del 2002 al 1004:

 

Sent:
INVITE sip:1004@10.10.0.11:5060 SIP/2.0
Via: SIP/2.0/UDP 10.10.0.31:5060;branch=z9hG4bK17156
Remote-Party-ID: <sip:2002@10.10.0.31>;party=calling;screen=no;privacy=off
From: <sip:2002@10.10.0.11>;tag=400A60-1C6A
To: <sip:1004@10.10.0.11>
Date: Tue, 24 Feb 2015 19:16:49 GMT
Call-ID: 844FFBDC-BB9011E4-8054EC0B-A815E59E@10.10.0.31
Supported: 100rel,timer,resource-priority,replaces,sdp-anat
Min-SE: 1800
Cisco-Guid: 2186434545-3146781156-2152721419-2820007326
User-Agent: Cisco-SIPGateway/IOS-12.x
Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER
CSeq: 101 INVITE
Max-Forwards: 70
Timestamp: 1424805409
Contact: <sip:2002@10.10.0.31:5060>
Expires: 180
Allow-Events: telephone-event
Content-Type: application/sdp
Content-Disposition: session;handling=required
Content-Length: 263

v=0
o=CiscoSystemsSIP-GW-UserAgent 673 495 IN IP4 10.10.0.31
s=SIP Call
c=IN IP4 10.10.0.31
t=0 0
m=audio 17176 RTP/AVP 0 101 19
c=IN IP4 10.10.0.31
a=rtpmap:0 PCMU/8000
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-16
a=rtpmap:19 CN/8000
a=ptime:20

…..

…..

Router#SIP/2.0 200 OK
Via: SIP/2.0/UDP 10.10.0.11:5060;branch=z9hG4bKa69a3425e
From: <sip:1004@10.10.0.11>;tag=33~e8b7b5a7-1eb5-494d-9850-73b8bd8a98c3-28509491
To: <sip:2002@10.10.0.11>;tag=400A60-1C6A
Date: Tue, 24 Feb 2015 19:16:54 GMT
Call-ID: 844FFBDC-BB9011E4-8054EC0B-A815E59E@10.10.0.31
Server: Cisco-SIPGateway/IOS-12.x
CSeq: 101 BYE
Reason: Q.850;cause=16
P-RTP-Stat: PS=149,OS=23840,PR=151,OR=24160,PL=0,JI=0,LA=0,DU=3
Content-Length: 0

Y como siempre, damos las gracias a los gigantes en cuyos hombros nos hemos apoyado, que esta vez son muchos y muy variados. Espero no dejarme a ninguno:

FRGTech Blog

Nityas World

Cisco Support Community

problutions.com

Mino – The UC Guy

Cisco Unified Border Element con CUCM

Comments are closed.