SIP codec negotiation

Siptrunkvideo1

Estoy disfrutando como un niño con zapatos nuevos. Son mis primeros laboratorios con video llamadas y la verdad es que me está enganchando.

Los softphones dan problemas. Cuando no es una cosa, es otra. Tengo una usb cam Logitech bastante normalita, y depende del softphone que elija, transmite video o no. Es un poquito para volverse loco. Con este laboratorio ya podemos estudiar los logs del debug ccsip messages. Tenemos un reto apasionante por delante.

Os copio la configuración del router 2801 con CME (Telephony-service Version 8.6).

 

Router#show run
Building configuration…
Current configuration : 2896 bytes

Last configuration change at 13:57:11 UTC Thu Apr 9 2015
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption

hostname Router

boot-start-marker
boot-end-marker

no aaa new-model

no network-clock-participate wic 3
dot11 syslog
ip source-route

ip dhcp excluded-address 192.168.3.1 192.168.3.10
ip dhcp excluded-address 20.20.0.1 20.20.0.10

ip dhcp pool Datos
network 192.168.3.0 255.255.255.0
default-router 192.168.3.1
option 150 ip 192.168.3.1

ip dhcp pool Voz
network 20.20.0.0 255.255.255.0
default-router 20.20.0.1
option 150 ip 20.20.0.1

ip cef
no ip domain lookup
no ipv6 cef

multilink bundle-name authenticated

voice service voip
no ip address trusted authenticate
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip

sip
registrar server expires max 3600 min 1800
asymmetric payload full
early-offer forced

voice class codec 10
codec preference 1 g711ulaw
video codec h263
video codec h263+
video codec h264

voice register global
mode cme
source-address 20.20.0.1 port 5060
bandwidth video tias-modifier 512000 negotiate end-to-end
max-dn 5
max-pool 5
authenticate register
authenticate realm all
tftp-path flash:
file text
create profile sync 0001671521306658
camera
video

voice register dn 3
number 203

voice register pool 3
id mac 00A0.D168.2709
number 1 dn 3
username 203 password 123456
codec g711ulaw
camera
video

voice-card 0

crypto pki token default removal timeout 0

license udi pid CISCO2801 sn FCZ101013AH

redundancy

controller T1 0/3/0

controller T1 0/3/1

interface FastEthernet0/0
no ip address
duplex auto
speed auto

interface FastEthernet0/0.5
description VLAN VOZ
encapsulation dot1Q 5
ip address 20.20.0.1 255.255.255.0

interface FastEthernet0/0.10
description VLAN DATOS
encapsulation dot1Q 10
ip address 192.168.3.1 255.255.255.0

interface FastEthernet0/1
ip address dhcp
duplex auto
speed auto
ip forward-protocol nd
no ip http server
no ip http secure-server

disable-eadi

control-plane

mgcp profile default

dial-peer voice 2 voip
description **Llamadas entrantes por el SIP TRUNK**
session protocol sipv2
session target ipv4:10.10.0.31
incoming called-number 2..
voice-class codec 10
dtmf-relay h245-alphanumeric
!
dial-peer voice 1 voip
description **Llamadas salientes por el SIP TRUNK**
destination-pattern 1…
session protocol sipv2
session target ipv4:10.10.0.11
voice-class codec 10
dtmf-relay rtp-nte

sip-ua
registrar ipv4:10.10.0.11 expires 3600
sip-server ipv4:10.10.0.11

gatekeeper
shutdown

line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
transport input all

scheduler allocate 20000 1000
end

 

 

Comments are closed.