Terminal Server Cisco

En este primer apunte, vamos a configurar un Terminal Server con un router Cisco.

En algunos video tutoriales de CCNA y CCNP vemos que el profesor está conectado por consola a varios dispositivos a la vez, y es muy chulo ver como va saltando de un router a otro simplemente picando en la pestaña que lleva el nombre del dispositivo.

 

Terminal_Server3

En primer lugar decirte que yo no he necesitado un Terminal Server  para preparar ninguno de mis exámenes de CCNA ni CCNP, pero bueno, me gusta buscar chatarra de segunda mano por internet y cacharrear con ella, y en mi caso lo conseguí de la siguiente forma.

Ingredientes necesarios para esta receta:

– Router Cisco 2610XM.

– Tarjeta NM-16A ASYNC

– El cable ese que parece un pulpo, CAB-OCTAL-ASYN.

cable_octal cab-octal-asyn

– El emulador de terminal SecureCRT.

¿Es necesario utilizar el programa SecureCRT?¿Se puede hacer lo mismo con PuTTY o con HyperTerminal o con TeraTerm o con cualquier otro emulador de terminal? Pues, no lo sé. Yo no he podido. Entre otras cosas, para salir de telnet, una combinación de teclas tan sencilla (siempre que tengas 2 manos ó 7 dedos) como CTRL + SHIFT +6 (pausa) + X se convertía en una auténtica locura, donde tenía que reiniciar el router porque era incapaz de salir, y SecureCRT me lo solucionó rápidamente con la opción Mapped Keys, donde a la tecla F1 por ejemplo le damos el valor \036\px y salimos de telnet sin mayor problema y con una sola mano.

También SecureCRT muestra las diferentes sesiones en una pestaña distinta sin mayor problema, siempre que sepas el truco, que consiste en tener el ordenador y el Terminal Server conectados por cable de red, vamos que puedan hacer ping entre ellos. No importa si los demás dispositivos no están en red, pero para poder tener más de una sesión abierta necesitas un cable de red entre tu ordenador y el Terminal Server, a parte de estar conectados por consola, claro. Ojito con esto por si estás pensando en comprarte el router Cisco 2511, necesitarás el AUI transceiver, que es tecnología del plestoceno para poder conectar ese router con tu ordenador.

transceiverAUI transceiver

Terminal_Server#show version

Cisco 2610XM (MPC860P) processor (revision 1.0) with 59392K/6144K bytes of memory.

Processor board ID JAE073302FC

M860 processor: part number 5, mask 2

1 FastEthernet interface

1 Serial interface

16 terminal lines

32K bytes of NVRAM.

16384K bytes of processor board System flash (Read/Write)

 

Configuration register is 0x2102

 

Terminal_Server#show version | include lines

16 terminal lines

 

Configuración del Terminal Server:

Terminal_Server#show run
Building configuration…

Current configuration : 1000 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Terminal_Server
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 10
no network-clock-participate slot 1
no network-clock-participate wic 0
ip cef
!
!
!
!
no ip domain lookup
ip host R1 2033 172.21.1.1
ip host SW1 2034 172.21.1.1
ip host R2 2035 172.21.1.1
!
!
!
!
!
!
!
interface Loopback1
ip address 172.21.1.1 255.0.0.0
!
interface FastEthernet0/0
ip address 192.168.1.131 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
no ip address
shutdown
!
ip default-gateway 192.168.1.1
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.1.1
!
no ip http server
no ip http secure-server
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
logging synchronous
line 33 48
exec-timeout 0 0
no exec
transport input all
line aux 0
transport preferred telnet
transport input all
line vty 0 4
exec-timeout 0 0
login
!
!
end

Bueno, para entender esto un poco lo primero que tenemos que hacer en el Terminal Server, una vez instalada la tarjeta NM-16A es ver qué líneas usa la tarjeta:

Terminal_Server#show line

33 TTY 9600/9600 – – – – – 2 1 35/106 –
34 TTY 9600/9600 – – – – – 4 19 0/0 –
35 TTY 9600/9600 – – – – – 0 0 0/0 –
36 TTY 9600/9600 – – – – – 0 0 0/0 –
37 TTY 9600/9600 – – – – – 0 0 0/0 –
38 TTY 9600/9600 – – – – – 0 0 0/0 –
39 TTY 9600/9600 – – – – – 0 0 0/0 –
40 TTY 9600/9600 – – – – – 0 0 0/0 –
41 TTY 9600/9600 – – – – – 0 0 0/0 –
42 TTY 9600/9600 – – – – – 0 0 0/0 –
43 TTY 9600/9600 – – – – – 0 0 0/0 –
44 TTY 9600/9600 – – – – – 0 0 0/0 –
45 TTY 9600/9600 – – – – – 0 0 0/0 –
46 TTY 9600/9600 – – – – – 0 0 0/0 –
47 TTY 9600/9600 – – – – – 0 0 0/0 –
48 TTY 9600/9600 – – – – – 0 0 0/0 –

y vemos que son de la 33 a la 48 (las TTY).

Creamos el dispositivo de red virtual que usaremos para hacer telnet (reverse telnet) a cada una de las lineas:

interface Loopback1
ip address 172.21.1.1 255.0.0.0

ip host R1 2033 172.21.1.1
ip host SW1 2034 172.21.1.1
ip host R2 2035 172.21.1.1

el número de puerto TCP es 2000 + número de línea. En el cable octal, el cable etiquetado con el nº 1, correspondería a la línea 33 del Terminal Server y le correspondería el puerto TCP 2033.

Cable etiquetado con el nº 2 —— línea 34 — puerto 2034

Cable etiquetado con el nº3 —— línea 35 — puerto 2035

y así con todos.

 

Terminal_Server#show ip interface brief

Interface                              IP-Address     OK? Method                  Status                          Protocol
FastEthernet0/0           192.168.1.131   YES NVRAM                       up                                   up
Serial0/0                            unassigned     YES NVRAM     administratively down     down
Loopback1                         172.21.1.1           YES NVRAM                        up                                   up

Y para conectar y desconectar con los otros routers:

Terminal_Server#telnet 192.168.1.131 2033

Trying 192.168.1.131, 2033 … Open

R1>

Volvemos al Terminal Server pulsando “control + shift + 6 + x “, o con F1 si hemos configurado el keymap de SecureCRT.

Terminal_Server#show sessions

Conn Host               Address             Byte Idle Conn Name

* 1 192.168.1.131      192.168.1.131         0     0 192.168.1.131

 

Terminal_Server#show line

Tty Typ     Tx/Rx   A Modem Roty AccO AccI   Uses   Noise Overruns   Int

*     0 CTY             –   –     –   –   –     1       0     0/0       –

*   33 TTY   9600/9600 –   –     –   –   –     1       3     0/0       –

34 TTY   9600/9600 –   –     –   –   –     0       0     0/0       –

 

Terminal_Server#disconnect 1

Closing connection to 192.168.1.131 [confirm]

Terminal_Server#

Añado varias capturas de pantalla como guía para configurar SecureCRT para que cada sesión se abra en una nueva ventana.

securecrt1 securecrt2 securecrt3 securecrt4 securecrt5 securecrt6

 

 

 

 

Hombros de gigante en los que me he apoyado para escribir este post:

configurar keymap SecureCRT

Cisco 2511

Cisco 2610XM-16TS

Configurar todo esto

Video en youtube

Reverse telnet

otra web

 

 

Comments are closed.